JupyterLab illustris_python warning

David Wang
  • 4
  • 17 Jul

Hi there,
I probably updated numpy or other library and then I got warning message when import illustris_python helper file. Should I switch back to which old version? Thanks!
Here is the warning message:
/opt/conda/lib/python3.6/importlib/_bootstrap.py:219: RuntimeWarning: numpy.dtype size changed, may indicate binary incompatibility. Expected 96, got 88
return f(*args, **kwds)
/opt/conda/lib/python3.6/site-packages/h5py/init.py:36: FutureWarning: Conversion of the second argument of issubdtype from float to np.floating is deprecated.In future, it will be treated as np.float64 == np.dtype(float).type. from ._conv import register_converters as _register_converters

Dylan Nelson
  • 18 Jul

Afraid I don't have any particular suggestion here, if you start to google these errors the typical response seems to be that they can be ignored.

Unless you find some issue, I would go with that.

David Wang
  • 18 Jul

Thanks, Dylan. I figured that out. It is due to I did not update numpy and hdf5 package. At first, I was thinking some bugs in the illustris helper function but it is not.

  • Page 1 of 1