OSError: Unable to open file

Jorge Romero Gómez
  • 23 Jun '23

Dear illustris team,

I have downloaded the Illistris-1 simulations, and the il.groupcat.loadHalos and subhalos work fine. But then when I try to load the stars of a subhalo a get the error:
OSError: Unable to open file (truncated file: eof = 283117686, sblock->base_addr = 0, stored_eof = 3188352392) i have tried with different subhalos and all give the same error.

I think there is some corrupt file. How can I fix this? Do I have to download all the data again?

Captura de pantalla 2023-06-23 a las 9.52.50.png

Dylan Nelson
  • 25 Jun '23

You're right, it seems you only downloaded part of a file. Probably it is only an issue with one (or a few) files. You could either (i) add a print statement inside loadSubhalo() to see which, or (ii) use the python debugger (type 'u' a few types until you are inside the loadSubhalo() function, then print(fileNum), or (iii) run e.g. h5ls or h5check on the files, any with errors will show up.

  • Page 1 of 1