Problem with downloading the group catalog

Fabio Lesjak
  • 1
  • 24 Apr '19


I am trying to download the FoF and Subfind Catalog of TNG100-1, using the batch download command provided on the download page. Around half of the downloaded files are 'fof_subhalo_tab' files containing the correct data, but the other half are called 'groupcat' and are only a couple of kilobytes. I tried this multiple times for snapshot 33 and 50, and everytime there are some of these unusable groupcat files. It seems to be random which of the 400+ files end up as groupcat files.

Here is on example of the console output for a succesfull download:
URL: [12704411/12704411] -> "fof_subhalo_tab_033.407.hdf5" [1]

and for an unsuccesfull download:
URL: [4297/4297] -> "groupcat-33.406.hdf5" [1]

Why is this happening and how can I download all of the group catalog files succesfully?

Thanks in advance.

Update: For now the problem seems to have disappeared. I tried it again exactly like before, and this time it works just fine.

Dylan Nelson
  • 30 Apr '19

Hi Fabio,

Yes I've had one other report of this in the past, but haven't yet tracked it down. Please let me know if it happens again, particularly if you get a particular link that repeatedly fails. Also good, if you get a strange failure, if you can note the exact time you tried it. Thanks!

Fabio Lesjak
  • 1 May '19

Hi Dylan,
interesting to know that I was not the only one with this problem. If it occurs again I will let you know.

  • Page 1 of 1